Friday, December 23, 2011

SQL Status: HY000 No Java installation could be found. Please check your installation.

http://www.computing.net/answers/office/open-officeorg-error/6779.html

http://www.oracle.com/technetwork/java/javase/downloads/jre-6u30-download-1377142.html

http://www.oooforum.org/forum/viewtopic.phtml?t=28899

Note: To change settings of Java Control Panel, launch Java Control Panel as administrator.

III. Configure Java Updates 

  1. Automatic Update Feature
    1. Click Start > Settings > Control Panel (For Windows XP)
      Click Start > Control Panel (For Windows Vista and Windows 7)
    2. Double-click Java icon. The Java Control Panel appears.
    3. Click the Update tab
      Note:
      • The Update tab may not be available if your network administrator has disabled the Java Update feature during installation.
      • If you are not logged in to system as administrator then options to change Java update notifications will be greyed out and user will not be able to change it.
    4. To enable Java Update to automatically check for updates, select the Check for Updates Automatically check box.
    5. To disable Java Update, un-select the Check for Updates Automatically check box.

  1. Change the notification options

  2. There are two notification options:
    1. Before installing: Use this option to download automatically and be notified before installing the Java update.
    2. Before downloading and before installing: This is the default option. Use this option to be notified before downloading and installing the Java update.

  1. Change the update schedule
    1. To change update notification frequency, click the Advanced button located next theCheck for Updates Automatically.
Scheduling Java update

    1. The Automatic Update Advanced Settings dialog box appears.
    2. Based on your preference, you can select the frequency to be daily, weekly, or monthly.
    3. You can choose the date and time for the Java Update.
    4. Click OK. The Java Update scheduler checks for newer Java updates at the scheduled frequency and notifies you.
Automatic update advance settings dialog box

  1. Manual Update Feature

  2. You can manually check for an update any time by clicking on Update Now.
Manual update feature

These other items may help you:

Wednesday, December 21, 2011

hijacking sites

i see all my traffic coming from these weird sites


Traffic SourcesMore ▸
http://www.777seo.com/seo.php?username=martyxmas&format=ptp
http://www.justforlaughsgags.tv
http://www.googlecorrection.com
http://domar.ru/ (the worst offender)
http://yandex.ru/yandsearch?text=

http://pu.gg


but going to the sites does not have any trace of links

Monday, December 19, 2011

new virus on facebook

as usual clicking on the link spreads the porn spam to all the friends on your list. It posts on your friends wall .




The words on the virus are some thing like the ones below 
[VIDEO] Yeahh!! It happens on Live Television!jsowieiwew.blogspot.comLol Checkout this video its very embracing moments for her

Saturday, December 10, 2011

Dolphin - boonex error events failed solution


.
 Goto Tools-> modules
Installation of: Events Failed
-- Check module dependencies:
-- -- The following modules should be installed first:
-- -- BoonEx Orca Forum Module
-- -- BoonEx Photos Module
-- -- BoonEx Videos Module
-- -- BoonEx Sounds Module



Installation of: Groups Failed
-- Check module dependencies:
-- -- The following modules should be installed first:
-- -- BoonEx Orca Forum Module
-- -- BoonEx Photos Module
-- -- BoonEx Videos Module
-- -- BoonEx Sounds Module
-- -- BoonEx Files Module




Thursday, December 1, 2011

Microsoft publisher alternative free publishing tools

Scribus is an Open Source program that brings professional page layout to Linux, Mac and Windows desktops
http://www.scribus.net/canvas/Scribus
Download Scribus


 54.5 MB file


PagePlus Starter Edition is an amazing tool for designing fantastic print documents. This version is 100% free and is yours to keep so download it now and start creating fabulous documents!
PagePlus Starter Edition Electronic Download     81.35 MB                                

Sunday, November 13, 2011

More malware spam on facebook via private message

Just saw this sent via facebook private message DO NOT CLICK ON THE LINK (JUST DELETE THE MESSAGE) 99 Percent Of People Cant Watch This Video For More Than 15 Seconds. Can you? shows.rain01.info << suspect site.


Facebook scare in Bangalore.

http://timesofindia.indiatimes.com/articleshow/10754012.cms 

 

Facebook profile spam porn -- Anonymous Fawkes malware?

http://blogs.computerworld.com/19282/facebook_profile_spam_porn_anonymous_fawkes_malware

Facebook newsfeeds hit with animal-cruelty, Bieber spam

3http://www.zdnet.com/blog/facebook/facebook-confirms-images-of-porn-and-violence-is-investigating/5330

 

 

another spam facebook video link

I Lost ALL Respect For MILEY CYRUS After Watching THIS Video!! very disturbing you will be really shocked at the video hxxp://www.facebook.com/pages/BBC-News-Videos/195437220536463?sk=app_190322544333196%2F it goes to some app . i wonder what this app does? I did not bother to investigate further

Saturday, November 12, 2011

SVG Viewer Plugin Installation


This page explains how to install the tools necessary to display SVG images using a web browser for Windows, Mac OS X and Linux. The information contained within this page is valid from the date of this document.

1) SVG for Windows

There are various tools to view SVG under Windows, including a special build of Mozilla, plugin from Corel, the Squiggle tool from the Apache Batik project, and finally the Adobe SVG Viewer plugin. At the time of writing, only the Adobe plugin is complete enough in order to use all the functionalities of the Navimages viewer. It is available as a 3.0.1 final release and as a 6 preview 1 release. Both versions work, but version 3.0.1 is more stable although the 6 preview 1 version has a few more features, including cursor support.
Most of computers with a Adobe Acrobat Reader plugin installed already have the Adobe SVG Viewer also installed, but an update may be necessary.
To install or update the Adobe SVG Viewer, you only have to download the installer (version 3.0.1 or 6 preview 1) and execute it. You may note that if you install more than one SVG plugin, the SVG Switcher tool may be useful for activating or deactivating the various versions.
When you make this installation, only the Internet Explorer will know about the plugin. If you wish to use it with a recent version of Mozilla or Firefox, you must copy the two files C:\Program Files\Common Files\Adobe\SVG Viewer 6.0\Plugins\NPSVG6.dll et C:\Program Files\Common Files\Adobe\SVG Viewer 6.0\Plugins\NPSVG6.zip in the plugins folder of your Mozilla/Firefox installation folder, and then restart it.

2) SVG for Linux

Adobe, Mozilla and the developers of GNOMEand KDE are actively working on the development of such tools.
A number of tools exist for viewing SVG images on Linux platforms. Some of these tools are: Squiggle,the viewer from theApache project. However, at the moment, the only web browser able to display SVG images is Mozilla (and its recent extension tools like Firefox).
A SVG engine is currently being developed by Mozilla for inclusion into the suite of products. This engine is completely independent of Adobe's SVG-Viewer. The goal of the project is to produce a SVG engine which respects closely the SVG standard. The current versions of Mozilla do not contain an active version of this SVG engine . However, it is still possible to install this engine. In order to do so, you must download the sources of the web browser and compile it with the necessary options. This is explained on the Mozilla SVG project website (http://www.mozilla.org/projects/svg/#get_it).
The KDE development team is currently working on KSVG to interface with their their web browserKonqueror. At the moment, it is simply a viewer.

2.1) Adobe SVG-Viewer for Mozilla

The best way to view SVG images is to use Adobe's SVG-Viewer. The windows installer is simple to use, but two files from this installation, C:\Program Files\Common Files\Adobe\SVG Viewer 6.0\Plugins\NPSVG6.dll and NPSVG6.zip, must be copied in to the "plugins" folder of you Mozilla installation. You must restart Mozilla for these changes to take affect. Adobe's SVG Viewer 6 Beta is the latest version.
The installation for Linux is more difficult. The viewer plugin available for Linux is only version 3 beta which should be easy install according to the Adobe documentationdocumenation. However, you could encounter a few problems which the documentation does not address.

2.1.1) Installation

While using: Linux 2.4.22. Mandrake 9.2. Mozilla 1.7 and Firefox 0.8. SVG-Viewer for Linux RedHat 3.01beta3 (December 2003).
  1. Download the plugin from the Adobe website : http://download.adobe.com/pub/adobe/magic/svgviewer/linux/3.x/3.01x88/en/adobesvg-3.01x88-linux-i386.tar.gz
  2. Login as "root"
  3. Copier the tar.gz archive to /usr/local

    Note

    Normally, we could install the plugin in any desired location, but the Adobe documentation clearly indicates that intensive tests were not carried-out in this area .
  4. Decompress the tar.gz archive : tar xzvf adobesvg-3.01-linux-i386.tar.gz
  5. Execute the installation script : ./install.sh
    Which will create a folder /usr/local/adobesvg-3.01 and a symbolic link pointing to/user/local/adobesvg/ .
    The script will then copylibNPSVG3.so to /usr/lib/mozilla/plugins, the default Mozilla "plugins" folder.
    If you have a standard Linux/Mozilla installation, you shouldn't have any problems. Otherwise, follow these steps:
  6. Copy the file /usr/local/adobesvg-3.01/libNPSVG3.so into the "plugins" directory of your web browser : {web browser installation directory}/plugins.
    For example : /opt/mozilla/1.7/plugins/ or /opt/firefox/0.8/plugins.

    Note

    Instead of copying the file, it is more useful to create a symbolic link.
  7. Create the environment variable ADOBE_SVG_VIEWER_PATH, set to the folder containing your Adobe SVG Viewer.
    Example : ADOBE_SVG_VIEWER_PATH = /usr/local/adobesvg-3.01/
    The environment variable can be create in the files : .cshrc, .profile ou .bashrc for the user.
    Example : for /home/{utilisateur}/.bashrc : export ADOBE_SVG_VIEWER_PATH=/usr/local/adobesvg-3.01
To test the installation, the Croczilla site of Mozillathe Mozilla project contains numerous SVG images.

3) SVG for Mac OS X

For Mac OS , you must use the Adobe SVG Viewer, version 3 plugin. For Mac OS X it works with the following browsers: Internet Explorer 5.2 , Safari 1.2, Mozilla 1.6 (Mozilla 5), Netscape 7 (Mozilla 5), Navigator 0.6 (Mozilla), and Camino 0.7 (Mozilla). For Mac OS 9 it works with the browsers: Internet Explorer 5 and Mozilla 1.0.3. The release notes from Adobe give more information about installation and support, although it is quite old now.

4) Testing

You may use the static examples of Navimages for testing your installations.

5) References

Some links to learn more and to stay abreast of current developments :
Adobesite for SVG
http://www.adobe.com/svg/main.html
The Mozilla Project
The MozillaSVG Project
http://www.mozilla.org/projects/svg/
TheMozilla site dedicated to SVG images
http://www.croczilla.com/svg
This site contains numerous SVG image examples. It is useful for testing your web browsers SVG support or plugin !
The SVG-Wiki site
http://www.protocol7.com/svg-wiki/ow.asp?GnuLinux
A generic SVG site containing a special section for each operating system.
The KSVG site
http://svg.kde.org/index.html

Friday, November 4, 2011

The reson for googles shitty search results in the past 6 months

I always wondered i type a very specific site xyz.com and it never came up on the first page of the search results for the past few month!!  This is really crazy logic

On the  blog 

If I search for [olympics], I probably want information about next summer’s upcoming Olympics, not the 1900

http://googleblog.blogspot.com/2011/11/giving-you-fresher-more-recent-search.html


When i types olympics i wanted info on olympics in general not olympics 2012? But i would like to read a complete article like the wikipedia articles. There are times i would like to get the lastest info but not always 
en.wikipedia.org/wiki/Olympic_Games




The aim is to return information about what users are actually searching for, rather than necessarily what they have typed in. --  Amit Singhal
http://www.telegraph.co.uk/technology/google/8870052/Google-improves-search-results.html

The problem with this logic (from search results)
The algo is trying to find the related keywords info which just does not relate to the specific search query (even if they search bot find the latest article with that related keyword) . Google need to monitor how many google pages a user  before they click on a search result or just leave google in frustration 


Update 21st Jan 2012 The Mountain View search giant blamed unfavorable foreign exchange rates and some recent changes in its search and advertising algorithms for the failure to meet expectations. http://www.mercurynews.com/business/ci_19783297?source=rss

This was expected thank to amit and matt cutts

Google voice search experiments: desert




This acoustic experiment for Google voice search was conducted in the middle of the Australian desert by two Google Australia engineers, using a Samsung Galaxy S II Android smartphone and two Parabolic Mirrors (http://goo.gl/X0Z2P).

Watch the video to see if it worked. Then why not try Google voice search for yourself!

Download Google voice search for Android (http://goo.gl/8CwQT) or iPhone (http://goo.gl/TfQsZ)

Watch more experiments at http://www.youtube.com/googlevoicesearch

Wednesday, November 2, 2011

Why wikipedias citation process is flawed



Wikipedia is a Mess, Wikipedians Say: 1 in 20 Articles Bare of References


http://en.wikipedia.org/wiki/Wikipedia:Wikipedia_Signpost/2011-10-31/Opinion_essay


Sven Manguard,talks about citation

The word "source" in Wikipedia has three meanings: the work itself (a document, article, paper, or book), the creator of the work (for example, the writer), and the publisher of the work (for example, The New York Times). All three can affect reliability.
 .

Here is a recent example



 A metallica concert was cancelled in delhi but the media (papers ) reported that the concert took place

Reasons why youtube is becoming a troll infested site

In the early days of youtube ,accounts were not linked to gmail so if a viewer wanted to comment they really had to work hard to get their profile verified and then comment.

With the automatic linking and lack of moderation (super for freedom of speech ) the ratio of trolls to productive commenter's have gone up  .

The best example is on music videos .



Taking a random example enter sandman by metallica


http://www.youtube.com/watch?v=1QP-SIW6iKY
likes, 3,509 dislikes 


 90% of videos have trolls who will comment like 


  • @xxx Bieber*
  • @xxx You're wrong, fucking bastard.

Google Sidewiki closing down

Dear Sidewiki contributor,

You are receiving this mail because you have contributed one or more entries to Sidewiki. We have decided to discontinue Sidewiki ( blog post), so we want to make sure you have a chance to export your valuable contributions.

To export your Sidewiki entries, go to http://www.google.com/sidewiki/ and follow the instructions. If you wish to export your Sidewiki entries, you will need to do this before December 5, 2011, after which time we’ll be discontinuing support for Sidewiki and deleting all content.

We’d like to take this opportunity to thank you for using Sidewiki and helping make it a compelling product.

Thanks,

The Sidewiki team

 googleblog.blogspot.com/2011/09/fall-spring-clean.html

http://investor.google.com/earnings/2011/Q3_google_earnings.html

https://plus.google.com/106189723444098348646/posts/dRtqKJCbpZ7

Sunday, October 30, 2011

possible malicious links in facebook chat ?

. name of chatter , This is so cool, we can now video chat on Facebook chat http://palsee.info/fpce0thr __ . name of chatter , video chat with me here http://nowpal.info/5prg0uo8 __ I have seen several of these link popup on facebook chat . not sure how they get there or how malicious they are .

tinyurl twitter spam

There was this link yesterday http://t.co/HUBkNTpZ The malicous? tweet read
serious about starting your own biz this year? check this out - http://tinyurl.com/3ggtnvd
which led to http://tinyurl.com/nospam.php?id=3ggtnvd on clicking the link it posts a tweet on your twitter account (tinyurl has not blocked the malicious link) Dont know what else this malicious link does .

Saturday, October 29, 2011

FLV video files do not play on VLC player in opensuse 11.4

Below is a dump of a opensuse newbie quest to find a solution by googling

I think the solution to all my video problems is codecs-gnome.ymp but i will still have to confirm this

Confirmed !! the above file installs all the required files you need to find videos and all the codecs . It may give you a warning on some files . I installed them anyway. 

Do you have compiz enabled. If yes, then open VLC, goto Settings->Preferences and check the Advanced options checkbox at botton of the settings window. Now expand Video from left column and click on output modules. In the drop menu on right side, select X11 video output. Click Save button and restart VLC. Check now with the FLV files.

does not work

rpm -qa | grep layer && rpm -q libffmpeg0 vlc kaffeine libxine1 xine-ui w32codec-all

pullin-flash-player-11.4.1-0.3.1.i586
flash-player-10.3.183.10-0.2.1.i586
package libffmpeg0 is not installed
vlc-1.1.12-1.15.i586
kaffeine-1.1-7.10.1.i586
libxine1-1.1.19-4.4.i586
package xine-ui is not installed
package w32codec-all is not installed
http://forums.opensuse.org/applications/395225-cant-play-flv-files.html


applications >system >configuration>install/remove software search for xine-ui and install


FLV videos still do not work in VLC

http://packman.links2linux.org/package/046


rpm -qa --qf "%{NAME} -> %{VENDOR}\n" | grep -i videolan
libmp3lame0 -> VideoLAN Project (http://www.videolan.org)
libva1 -> VideoLAN Project (http://www.videolan.org)
libavcodec53 -> VideoLAN Project (http://www.videolan.org)
libopencore-amrwb0 -> VideoLAN Project (http://www.videolan.org)
libxvidcore4 -> VideoLAN Project (http://www.videolan.org)
vlc-gnome -> VideoLAN Project (http://www.videolan.org)
libmad0 -> VideoLAN Project (http://www.videolan.org)
libdvdcss2 -> VideoLAN Project (http://www.videolan.org)
libvpx0 -> VideoLAN Project (http://www.videolan.org)
libx264-119 -> VideoLAN Project (http://www.videolan.org)
liba52-0 -> VideoLAN Project (http://www.videolan.org)
libvlc5 -> VideoLAN Project (http://www.videolan.org)
libavformat53 -> VideoLAN Project (http://www.videolan.org)
vlc -> VideoLAN Project (http://www.videolan.org)
libdca0 -> VideoLAN Project (http://www.videolan.org)
libopencore-amrnb0 -> VideoLAN Project (http://www.videolan.org)
libupnp6 -> VideoLAN Project (http://www.videolan.org)
libmpeg2-0 -> VideoLAN Project (http://www.videolan.org)
libpostproc51 -> VideoLAN Project (http://www.videolan.org)
vlc-noX -> VideoLAN Project (http://www.videolan.org)
vlc-aout-pulse -> VideoLAN Project (http://www.videolan.org)
libtwolame0 -> VideoLAN Project (http://www.videolan.org)
libavutil51 -> VideoLAN Project (http://www.videolan.org)
vlc-qt -> VideoLAN Project (http://www.videolan.org)
libvlccore4 -> VideoLAN Project (http://www.videolan.org)
libfaad2 -> VideoLAN Project (http://www.videolan.org)
libswscale2 -> VideoLAN Project (http://www.videolan.org)
http://forums.opensuse.org/english/get-technical-help-here/applications/395225-cant-play-flv-files-2.html


rpm -qa | grep layer && rpm -q libffmpeg0 vlc kaffeine libxine1 xine-ui w32codec-all
pullin-flash-player-11.4.1-0.3.1.i586
flash-player-10.3.183.10-0.2.1.i586
package libffmpeg0 is not installed
vlc-1.1.12-1.15.i586
kaffeine-1.1-7.10.1.i586
libxine1-1.1.19-4.4.i586
xine-ui-0.99.5-231.1.i586
package w32codec-all is not installed

http://forums.opensuse.org/english/get-technical-help-here/multimedia/412343-got-error-while-trying-install-codec-libffmpeg0.html

how to install packages on opensuse
sudo zypper


 sudo zypper

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.


  Usage:
        zypper [--global-options] [--command-options] [arguments]

  Global Options:
        --help, -h              Help.
        --version, -V           Output the version number.
        --config, -c      Use specified config file instead of the default.
        --quiet, -q             Suppress normal output, print only error
                                messages.
        --verbose, -v           Increase verbosity.
        --no-abbrev, -A         Do not abbreviate text in tables.
        --table-style, -s       Table style (integer).
        --rug-compatible, -r    Turn on rug compatibility.
        --non-interactive, -n   Do not ask anything, use default answers
                                automatically.
        --xmlout, -x            Switch to XML output.

        --reposd-dir, -D


  Use alternative repository definition file
                                directory.
        --cache-dir, -C    Use alternative directory for all caches.
        --raw-cache-dir    Use alternative raw meta-data cache directory.
        --solv-cache-dir   Use alternative solv file cache directory.                                                                                                                                
        --pkg-cache-dir    Use alternative package cache directory.                                                                                                                                  
                                                                                                                                                                                                          
     Repository Options:                                                                                                                                                                                  
        --no-gpg-checks         Ignore GPG check failures and continue.                                                                                                                                   
        --gpg-auto-import-keys  Automatically trust and import new repository                                                                                                                             
                                signing keys.                                                                                                                                                             
        --plus-repo, -p    Use an additional repository.                                                                                                                                             
        --disable-repositories  Do not read meta-data from repositories.                                                                                                                                  
        --no-refresh            Do not refresh the repositories.                                                                                                                                          
        --no-cd                 Ignore CD/DVD repositories.                                                                                                                                               
        --no-remote             Ignore remote repositories.                                                                                                                                               
                                                                                                                                                                                                          
     Target Options:
        --root, -R         Operate on a different root directory.
        --disable-system-resolvables
                                Do not read installed packages.

  Commands:
        help, ?                 Print help.
        shell, sh               Accept multiple commands at once.

     Repository Management:
        repos, lr               List all defined repositories.
        addrepo, ar             Add a new repository.
        removerepo, rr          Remove specified repository.
        renamerepo, nr          Rename specified repository.
        modifyrepo, mr          Modify specified repository.
        refresh, ref            Refresh all repositories.
        clean                   Clean local caches.

     Service Management:
        services, ls            List all defined services.
        addservice, as          Add a new service.
        modifyservice, ms       Modify specified service.
        removeservice, rs       Remove specified service.
        refresh-services, refs  Refresh all services.

     Software Management:
        install, in             Install packages.
        remove, rm              Remove packages.
        verify, ve              Verify integrity of package dependencies.
        source-install, si      Install source packages and their build
                                dependencies.
        install-new-recommends, inr
                                Install newly added packages recommended
                                by installed packages.

     Update Management:
        update, up              Update installed packages with newer versions.
        list-updates, lu        List available updates.
        patch                   Install needed patches.
        list-patches, lp        List needed patches.
        dist-upgrade, dup       Perform a distribution upgrade.
        patch-check, pchk       Check for patches.

     Querying:
        search, se              Search for packages matching a pattern.
        info, if                Show full information for specified packages.
        patch-info              Show full information for specified patches.
        pattern-info            Show full information for specified patterns.
        product-info            Show full information for specified products.
        patches, pch            List all available patches.
        packages, pa            List all available packages.
        patterns, pt            List all available patterns.
        products, pd            List all available products.
        what-provides, wp       List packages providing specified capability.

     Package Locks:
        addlock, al             Add a package lock.
        removelock, rl          Remove a package lock.
        locks, ll               List current package locks.
        cleanlocks, cl          Remove unused locks.

     Other Commands:
        versioncmp, vcmp        Compare two version strings.
        targetos, tos           Print the target operating system ID string.
        licenses                Print report about licenses and EULAs of
                                installed packages.

Type 'zypper help ' to get command-specific help.
http://techhamlet.com/2009/11/suse-zypper-manage-software-from-terminal/

sudo zypper in libavcodec52 libdvdnav4 libdvdread4 libffmpeg0 libquicktime0 libxine1 libxine1-codecs libxvidcore4 w32codec-all xvidcore


 sudo zypper in libavcodec52 libdvdnav4 libdvdread4 libffmpeg0 libquicktime0 libxine1 libxine1-codecs libxvidcore4 w32codec-all xvidcore
Loading repository data...
Reading installed packages...
Package 'libxine1-codecs' not found.
'libxvidcore4' is already installed.
No update candidate for 'libxvidcore4-1.3.2-1.2.i586'. The highest available version is already installed.
'xvidcore' not found in package names. Trying capabilities.
'libxvidcore4' providing 'xvidcore' is already installed.
'libxine1' is already installed.
No update candidate for 'libxine1-1.1.19-4.4.i586'. The highest available version is already installed.
'libdvdread4' is already installed.
No update candidate for 'libdvdread4-4.1.3-15.1.i586'. The highest available version is already installed.
'libdvdnav4' is already installed.
No update candidate for 'libdvdnav4-4.1.3-11.1.i586'. The highest available version is already installed.
'libavcodec52' not found in package names. Trying capabilities.
No provider of 'libavcodec52' found.
'libffmpeg0' not found in package names. Trying capabilities.
No provider of 'libffmpeg0' found.
'libquicktime0' not found in package names. Trying capabilities.
No provider of 'libquicktime0' found.
'w32codec-all' not found in package names. Trying capabilities.
No provider of 'w32codec-all' found.
Resolving package dependencies...

Nothing to do.



after all the googling the below file just popped up on my search and it stared to install the files needed to play the videos

http://opensuse-community.org/codecs-gnome.ymp
An easy way to install a selection of popular multimedia codecs, including:
* Flash
* Java
* Encrypted DVD
* Extra XINE Codecs, for DivX/Xvid etc. (libxine1)
* Win 32 Codecs (w32codec-all)

...as well as have the option to install other additional software that might not be shipped with openSUSE.

Click "Customise" on the next screen to get the option to select more software.

For more information see http://opensuse-community.org/Restricted_Formats

If you continue, the following changes will be made to your system:
Repositories to be added:
http://download.opensuse.org/distribution/11.4/repo/non-oss (openSUSE-11.4-Non-Oss)
http://download.opensuse.org/distribution/11.4/repo/oss (openSUSE-11.4-Oss)
http://download.opensuse.org/update/11.4/ (openSUSE-11.4-Update)
http://opensuse-guide.org/repo/11.4/ (libdvdcss repository)
http://packman.inode.at/suse/openSUSE_11.4/ (Packman Repository)
Note:

You will remain subscribed to these repositories after installation.
Software to be installed:
MPlayer
ffmpeg
flash-player
gmplayer
gstreamer-0_10-ffmpeg
gstreamer-0_10-plugins-bad
gstreamer-0_10-plugins-good
gstreamer-0_10-plugins-ugly
k3b-codecs
libdvdcss2
libxine1-codecs
phonon-backend-vlc
smplayer
vlc


# Status             Package                        | Summary                                  | Installed (Available)     |       Size

[Autoinstall]        MPlayer                        | Multimedia Player                        | (1.0rc4_r34240-2.1)       |   47.0 MiB
[Autoinstall]        ffmpeg                         | Hyper fast MPEG1/MPEG4/H263/RV and AC... | (0.8.5-1.2)               |    1.8 MiB
[Autoupdate]         flash-player                   | Adobe Flash PlugIn and standalone Player | 10.3.183.10-0.2.1 (10.2.152.26-2.1) |   20.7 MiB
[Autoinstall]        gmplayer                       | GUI Frontend for the MPlayer Multimed... | (1.0rc4_r34240-2.1)       |  272.0 KiB
[Autoinstall]        gstreamer-0_10-ffmpeg          | GStreamer Streaming-Media FFmpeg Plug-In | (0.10.11-1000.10)         |    5.9 MiB
[Autoinstall]        gstreamer-0_10-plugins-bad     | GStreamer Streaming-Media Framework P... | (0.10.22-135.1)           |    4.7 MiB
[Autoupdate]         gstreamer-0_10-plugins-good    | GStreamer Streaming-Media Framework P... | 0.10.28-1.2.1 (0.10.30-60.4) |    4.6 MiB
[Autoinstall]        gstreamer-0_10-plugins-ugly    | GStreamer Streaming-Media Framework P... | (0.10.18-28.1)            |  362.0 KiB
[Autoinstall]        k3b-codecs                     | Full Multimedia Codec Support for k3b    | (2.0.2-13.6)              |  183.0 KiB
[Autoinstall]        kdebase4-runtime-xine          | The KDE Runtime Components               | (4.6.0-4.9.1)             |   31.0 KiB
[Autoinstall]        libbluray0                     | Blu-Ray Disc Playback Library            | (0+20111019-1.1)          |  162.0 KiB
[Autoinstall]        libbs2b0                       | Shared libraries for bs2b                | (3.1.0-1.pm.4.1)          |   22.0 KiB
[Autoinstall]        libcrystalhd3                  | Broadcom Crystal HD device interface ... | (3.6.4-4.1)               |  122.0 KiB
[Autoinstall]        libdirac_decoder0              | Dirac Video Codec Decoder Library        | (1.0.2-12.1)              |  408.0 KiB
[Autoinstall]        libdirac_encoder0              | Dirac Video Codec Encoder Library        | (1.0.2-12.1)              |  577.0 KiB
[Autoupdate]         libdvdcss2                     | Library for accessing DVDs like block... | 1.2.10-10.2 (1.2.10-2.pm.3.1) |   53.0 KiB
[Autoinstall]        libfaac0                       | FAAC Shared library                      | (1.28-3.3)                |   72.0 KiB
[Autoinstall]        libmpg123-0                    | Realtime Player Library for MPEG Audi... | (1.13.4-1.pm.1.2)         |  200.0 KiB
[Autoinstall]        librtmp0                       | RTMP Stream Dumper Library               | (2.3.99.git20110728-1.pm.1.2) |  120.0 KiB
[Autoinstall]        libsidplay1                    | A Library for C64 Music Files            | (1.36.59-146.pm.148.4)    |  271.0 KiB
[Autoinstall]        libvdpau1                      | VDPAU wrapper library                    | (0.4.1-10.6)              |   33.0 KiB
[Autoinstall]        libxine1-codecs                | Xine plugins for watching DVDs, DivX ... | (1.1.19-50.13)            |    1.5 MiB
[Autoinstall]        phonon-backend-vlc             | Phonon VLC Backend                       | (0.3.2-6.2)               |  201.0 KiB
[Autoinstall]        phonon-backend-xine            | Phonon Multimedia Platform Abstraction   | (4.4.4-3.1)               |  310.0 KiB
[Autoinstall]        smplayer                       | Complete Frontend for MPlayer            | (0.6.9+r3615-1.pm.1.1)    |    2.6 MiB
[Autoupdate]         vlc                            | VLC - Video Lan Client                   | 1.1.12-1.15 (1.1.12-7.1)  |    2.0 MiB

Installation notes of hplip-3.11.10.run - HP Printer driver

sh hplip-3.11.10.run
Creating directory hplip-3.11.10
Verifying archive integrity... All good.
Uncompressing HPLIP 3.11.10 Self Extracting Archive....................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................                                                                                                  
                                                                                                                                                                                                          
HP Linux Imaging and Printing System (ver. 3.11.10)                                                                                                                                                       
HPLIP Installer ver. 5.1                                                                                                                                                                                  
                                                                                                                                                                                                          
Copyright (c) 2001-9 Hewlett-Packard Development Company, LP                                                                                                                                              
This software comes with ABSOLUTELY NO WARRANTY.                                                                                                                                                          
This is free software, and you are welcome to distribute it                                                                                                                                               
under certain conditions. See COPYING file for more details.                                                                                                                                              
                                                                                                                                                                                                          
Installer log saved in: hplip-install_.log                                                                                                                                        
                                                                                                                                                                                                          
/                                                                                                                                                                                                         
note: Defaults for each question are maked with a '*'. Press to accept the default.


INSTALLATION MODE
-----------------
Automatic mode will install the full HPLIP solution with the most common options.
Custom mode allows you to choose installation options to fit specific requirements.

Please choose the installation mode (a=automatic*, c=custom, q=quit) : a

Initializing. Please wait...


INTRODUCTION
------------
This installer will install HPLIP version 3.11.10 on your computer.
Please close any running package management systems now (YaST, Adept, Synaptic, Up2date, etc).


DISTRO/OS CONFIRMATION
----------------------
Distro appears to be SUSE Linux 11.4.

Is "SUSE Linux 11.4" your correct distro/OS and version (y=yes*, n=no, q=quit) ? y


ENTER ROOT/SUPERUSER PASSWORD
-----------------------------
Please enter the root/superuser password:
Password accepted


INSTALLATION NOTES
------------------
Please be sure to disable the CD repositories in YaST and after installation you must log out and back in to become a member of the lp and sys group to enable printing.

Please read the installation notes. Press to continue or 'q' to quit:


RUNNING PRE-INSTALL COMMANDS
----------------------------
OK


INSTALL MISSING REQUIRED DEPENDENCIES
-------------------------------------
warning: There are 8 missing REQUIRED dependencies.
note: Installation of dependencies requires an active internet connection.
warning: Missing REQUIRED dependency: gcc (gcc - GNU Project C and C++ Compiler)
warning: Missing REQUIRED dependency: libpthread (libpthread - POSIX threads library)
warning: Missing REQUIRED dependency: python-devel (Python devel - Python development files)
warning: Missing REQUIRED dependency: cups-devel (CUPS devel- Common Unix Printing System development files)
warning: Missing REQUIRED dependency: libusb (libusb - USB library)
warning: Missing REQUIRED dependency: libtool (libtool - Library building support services)
warning: Missing REQUIRED dependency: cups-image (CUPS image - CUPS image development files)
warning: Missing REQUIRED dependency: libjpeg (libjpeg - JPEG library)


INSTALL MISSING OPTIONAL DEPENDENCIES
-------------------------------------
warning: There are 7 missing OPTIONAL dependencies.
note: Installation of dependencies requires an active internet connection.
warning: Missing REQUIRED dependency for option 'network': libcrypto (libcrypto - OpenSSL cryptographic library)
warning: Missing REQUIRED dependency for option 'network': libnetsnmp-devel (libnetsnmp-devel - SNMP networking library development files)
warning: Missing OPTIONAL dependency for option 'gui_qt4': python-notify (Python libnotify - Python bindings for the libnotify Desktop notifications)
warning: Missing OPTIONAL dependency for option 'fax': reportlab (Reportlab - PDF library for Python)
warning: This installer cannot install 'reportlab' for your distro/OS and/or version.
warning: Missing REQUIRED dependency for option 'fax': dbus (DBus - Message bus system)
warning: Missing REQUIRED dependency for option 'scan': sane-devel (SANE - Scanning library development files)
warning: Missing OPTIONAL dependency for option 'scan': pil (PIL - Python Imaging Library (required for commandline scanning with hp-scan))


CHECKING FOR NETWORK CONNECTION
-------------------------------
Network connection present.


RUNNING PRE-PACKAGE COMMANDS
----------------------------
su -c "zypper refresh" (Pre-depend step 1)
OK


DEPENDENCY AND CONFLICT RESOLUTION
----------------------------------
Running 'su -c "zypper --non-interactive --no-gpg-checks in --auto-agree-with-licenses gcc-c++"'
Please wait, this may take several minutes...